Scheduled for May 07, 2024 at 4:30 PM – 4:38 PM
Affects
EMX
Under maintenance from 4:30 PM to 4:38 PM
Completed
May 07, 2024 at 4:38 PMCompleted
May 07, 2024 at 4:38 PMMaintenance has completed successfully.
Planned
May 07, 2024 at 4:30 PMPlanned
May 07, 2024 at 4:30 PMEMX 4.0 will be released on May 7, 2024
In progress
May 07, 2024 at 4:29 PMIn progress
May 07, 2024 at 4:29 PMMaintenance is now in progress.