Scheduled for June 28, 2023 at 4:00 PM – 5:47 PM
Affects
EMX
Under maintenance from 4:00 PM to 5:47 PM
Completed
June 28, 2023 at 5:47 PMCompleted
In progress
June 28, 2023 at 5:44 PMIn progress
June 28, 2023 at 5:44 PMMaintenance is now in progress.
Planned
June 28, 2023 at 4:00 PMPlanned
June 28, 2023 at 4:00 PMEMX 3.8.0 will be released June 27th, 2023