Scheduled for March 18, 2026 at 4:00 PM – 4:18 PM
Affects
EMX
Under maintenance from 4:00 PM to 4:18 PM
Completed
March 18, 2026 at 4:18 PMCompleted
March 18, 2026 at 4:18 PM3.18.0 has been released.
In progress
March 18, 2026 at 4:05 PMIn progress
March 18, 2026 at 4:05 PMRelease is now in progress.
Planned
March 18, 2026 at 4:00 PMPlanned
March 18, 2026 at 4:00 PMEMX 4.18.0 will be released on Wednesday, March 18th